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About Softwave

1

Softwave is Wave's companion software. Softwave allows users to fully customize 

Wave by creating their own presets and preset banks. It can either help users 

intuitively map Wave's functions to their DAW of choice or host their favourite 

VST3 and AU plugins. Softwave also has a built in sound engine and comes pre-

loaded with fifteen curated presets so you can start making music immediately�

R  When using Wave with your DAW keep Softwave open in the background�

R Softwave is not a VST plugin�

R Softwave does not work on your mobile.



Installing on Windows
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When you open Softwave for the first time you might get a notification.




Please select Learn more and Run anyway.




Softwave will ask you to install loopMIDI, a virtual MIDI driver, if it's not already 

installed. If for some reason this does not happen, the driver can be found here.


Note that your browser may prompt a warning when trying to download 

loopMIDI, but we assure you that it's completely safe.

1
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3

If you have an older version of Softwave installed



It's preferable to completely remove the Korg BLE MIDI driver from the 

system. To do this head through Settings → Apps, search for "Korg BLE 

MIDI" and click "Uninstall." Verify that the driver is not present in Device 

Manager → Sound, video and game controllers or Device Manager → 

Software devices. Restart the computer.



Interface guide

3

Wave

Preset Bank

This is where you connect 
Wave, up to two Waves at a 
time. When Wave is connected 
to Softwave you can access 
Wave's configuration panel  
by pressing the gear icon, 
configure Standalone mode 
and Wavefront and see  
Wave's battery status.

The preset bank holds  
the presets you're working 
with at any given time. 
Create or delete presets, 
save your preset bank,  
or load in new ones.
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Preset

Functions within a preset

Each preset can be 
configured individually. 
Give it a descriptive name, 
add a VST or Audio plugin 
to it, change between 
Relative and Absolute mode 
and set MIDI Channel and/
or Program change.

Add functions to your 
preset and customize 
them; the movement and 
output range, movement 
direction and curve, mute, 
solo and add CC values, 
notes or key commands.



Connecting Wave to Softwave
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Press "A Connect Wave" in the top left corner of Softwave.



Select Wave from the list that appears.



Close the window.



Wave should be connected to your computer.



To connect a 2nd Wave to Softwave press "B Connect Wave" 

and repeat steps 2-4

1

2
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To connect Wave make sure it is turned on.


You turn Wave on by pressing its Middle button.


Also make sure Bluetooth is turned on in your computer.



After you connect Wave, Softwave remembers it and autoconnects to it next time 

you turn your Wave on.

Troubleshootin�

� If you have an older version of Softwave installed and already installed the 

KORG driver, it is preferable to completely remove the Korg BLE MIDI driver 

from the system. To do this head through Settings → Apps, search for "Korg 

BLE MIDI" and click "Uninstall." Verify that the driver is not present in Device 

Manager → Sound, video and game controllers or Device Manager → 

Software devices. Restart the computer̀

� If Wave gets in a strange connect/disconnect loop with the system (lights 

flashing on/off). This seems to happen if you've previously paired Wave 

through Windows's system settings. Pairing is not necessary, and removing 

Wave through the system's Bluetooth settings will fix the issue. You can still 

connect through Softwave just fine`

� If you're experiencing a slow or jittery connection, that might be due to old or 

outdated Bluetooth drivers. Make sure you have the latest drivers installed for 

your system. If the drivers are up to date and you still experience issues, 

consider using an external USB dongle instead. We've found this dongle to 

work best in our tests.



Button configuration
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These are the default settings for Wave within Softwave.



These settings can be customized to your own liking in Wave's configuration panel.

Wave has 3 buttons; Up, Middle and Down. The Middle button activates and 

deactivates Wave. Simply put you can deactivate Wave so you can scratch your 

nose without affecting sound every time you do it.



Holding the Middle button will Reset the movements to their starting point.



The Up and Down buttons act as navigation buttons. You use them to navigate 

between the presets in Softwave. Try navigating between presets while playing 

to change the sound in Softwave and functions on Wave.

Click middle

button to 

turn on

Click lower 
button for

next preset

Click upper 
button for

previous 
preset

Long press  
to reset  
movements



Icon list
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Wave configuration panel

Wave configured on Right hand

Wave configured on Left hand

Activate/Deactivate Wave

Reset Wave to starting point

Standalone mode editor

Wavefront editor

R

L

Wave

Create new preset

Save preset bank

Load preset bank

Delete preset

Preset Bank

Opens plugin window

Auto opens plugin window

Auto activates Wave

Wave is set to Relative movements

Wave is set to Absolute movements

Preset channel & program

Presets

Rel

Abs

Tilt Assigned to Wave A

Pan Assigned to Wave B

Roll Movements direction

Vibrato Movement curve

Tap Solo function

Middle button Mute function

Up button Assign MIDI CC or Note

Down button Assign Key command

Functions

Key

S

M

A

B



Using two Waves within Softwave

8

You can use two Waves within Softwave at a time - Wave A and Wave B.

Connecting a second Wave



To connect a second Wave to Softwave press "B Wave" at the top left corner of 

Softwave. Then follow the same steps as before when you connected the first 

Wave



Changing Wave A to Wave B and vice versa



To change Wave A to Wave B select Wave A and drag it down under Wave B.


The two connected Waves should change roles.



Mapping functions to Wave B



Automatically all new functions you add to your preset are mapped to Wave A.



To map functions over to Wave B press the A in the lower left corner of the 

function window. It should turn from brown to white and read B instead of A.



Repeat for all functions you want to map over to Wave B.



Identifying which Wave is which



In the top left corner of Softwave press the name of the Wave you want to 

identify. The LED screen on that Wave will light up.



Disconnecting Wave from Softwave
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Turn Wave off by holding the Up and Down buttons simultaneously.



Simply close Softwave.



To completely disconnect Wave you can navigate to Menu 

→ Connect Bluetooth Device and press the "x" behind the  

connected Wave. This way Softwave will forget Wave.

1

2

3

To disconnect Wave from Softwave you can:

Note that Softwave has a built in auto-connect feature, so the next time you open 

Softwave it will connect automatically to Wave unless you do this.



Preset Configuration Panel
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At the top of every Preset you'll find the Preset Configuration Panel.



Preset name



On the left side of the panel you'll see the preset number and preset name. 

To rename the preset; click the Preset name. You can now write a new name. 

Press Enter when done or click with the mouse cursor outside the box.



Renaming Presets to a descriptive name can help organise your workflow; 

"Recording," "Automating strings" etc.



Selecting a plugin



Each preset can host its own plugin (VST3/AU). This way it’s easy to move 

between plugins and sounds. To select a plugin click the box where it reads 

"Select Plugin." If the preset is already hosting a plugin the box will read the 

name of that particular plugin.



Opening a plugin

To see the plugin your preset is hosting press this icon.



For plugins to automatically open when you navigate to a preset 

press this icon.

Select this icon if you want Wave to activate automatically when 

you navigate to that particular preset. This feature is default in all 

new presets.

Auto activating a Preset
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Relative vs Absolute



Within each preset you can decide if Wave uses Relative (Rel) or Absolute (Abs) 

movements. The default state for Wave is Relative.



Relative mode behaves in a way that when you deactivate a preset, no matter 

how you move your hand in between, when you reactivate it the ring will start 

tracking from the last position before deactivating.



The Absolute mode does the opposite. It keeps tracking your movements even 

if you've deactivated the preset, and "jumps" to the current value when you 

reactivate it.



Absolute is stuck in space, Relative moves with you.



MIDI channel



You can select a MIDI Channel for each preset. Press the MIDI icon in the top 

right corner of Softwave. Change the number for the channel by pressing the 

number and selecting from the list. The default is Channel 1.



Program change



You can set a Program Change for each preset. This way, every time you 

navigate to that particular preset, it will send out the program change. Select 

the MIDI icon in the top right corner of Softwave to set the Program Change, 

Bank MSB and Bank LSB.



Hosting VST3/AU plugins within Softwave

12

Each preset can host its own plugin (VST/AU). Therefore you can use Softwave 

on its own without the need for a DAW when you're playing.



Selecting a plugin



To select a plugin click the box where it reads „Select plugin.“ If the preset is 

already hosting a plugin the box will read the name of that particular Plugin.



Scanning for available plugins



You need to scan for the plugins on your computer for Softwave to know which 

plugins are available. You can scan for VST3 and AU plugins.

To scan for your plugins navigate to the top left corner of your screen 

to Menu. Select "Scan for plugins." A window opens.



Press "Options..." and select "Scan for new or updated AudioUnit-or-

VST3 plug-ins." This might take a while if you have a lot of plugins on 

your computer.



When the scanning process is over close the window.



All of your plugins should now be available in the "Select plugin" list 

within each Preset.

1

2

3

4
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Option 2

Open the plugin by pressing this icon.



At the top of each plugin you'll see the icons of all the functions 

within the preset. Press the icon of the function you want to map. 

It should turn brown.



Next move the parameter you want to map. The name of the 

parameter should appear next to the icon at the top. The 

parameter and function are mapped together.



Repeat for other functions or if you want to remap an already 

mapped function.

1

2

3

4

Mapping function to plugin parameters



There are two options to map functions to plugin parameters.



Option 1

Press the "Select parameter" at the top of the function window 

you want to map.



A dropdown appears with all available parameters.



Select the one you want to map.



Repeat for other functions or if you want to remap an already 

mapped function.

1

2

3

4



Preset Bank

Creating & Managing Presets
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Softwave holds one Preset Bank at a time#

0 A preset bank is a bank of presets. Each preset bank can hold endless 

amounts of presets#

0 A preset is a combination of functions that each has a certain purpose. Each 

preset can hold up to 8 functions#

0 A function is one of the following: Tilt, Pan, Roll, Vibrato, Tap or Click.

It's easy to create new presets, delete them, rename them or move them in 

order to customize your workflow to your needs.

Creating a new preset



To create a new preset click the “+Preset” icon.



Renaming the preset bank



To rename the preset bank, click the "Default Preset Bank." You can now write 

in a new name. Press Enter when done or click with your mouse cursor outside 

the box



Renaming presets



There are two ways to rename presets#

0 To rename a preset in the preset list; click on the Preset name. You can now 

write a new name. Press Enter when done or click with the mouse cursor 

outside the box#

0 To rename a preset in the top left corner of the preset window; click the 

Preset name. You can now write a new name. Press Enter when done or 

click with the mouse cursor outside the box.
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Rearranging the Preset Bank



To rearrange Presets in your Preset Bank simply click and hold the preset 

number and drag it to the desired location.



Renaming the preset bank



To rename the preset bank, click the "Default Preset Bank." You can now write 

in a new name. Press Enter when done or click with your mouse cursor outside 

the box



Deleting a preset



To delete a Preset click the "x" behind the Preset in the Preset Bank list.



Restoring a deleted preset



If you accidentally delete a Preset and haven't saved your session you can use 

cmd+z (Mac) or ctrl+z (Windows) to undo your mistakes.

Saving & Loading

Softwave holds one Preset Bank at a time. You can save and load preset banks 

so you can store multiple banks and even share them with others.

Saving a preset bank

Loading Presets: Load new & Add to bank

To save a Preset Bank click this icon.

To load a new Preset Bank click this icon and select "Load new." You can 

select a previously saved Preset Bank and load it into Softwave. This will 

swap the current bank out for the new one.

To add Presets into your Preset Bank click this icon and select "Add to 

bank." A window opens showing an overview of the previously saved 

Preset Bank. You can choose which of these presets you'll add to your 

current bank. Deselect the Presets you don't want to add and press "Ok."



DAWs
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CC numbers



In order to map functions from Softwave to your DAW (such as Ableton Live or 

Logic Pro) you need to attach a MIDI CC number to the function.

Some DAWs such as Cubase and Pro Tools have some of their CC values hard 

coded, so you can't use all of them.



Additionally you can assign:

You can assign any CC number, but make sure each function has an individual 

number. Softwave uses this number to communicate with your DAW.

PB (Pitchbend) to Tilt, Pan, Roll and Vibrato.



Notes (C, C#, D, E, F etc.) when using the Tap function.



Notes and Key commands/Shortcuts (cmd+T, R, f12 etc.) when using 

the Click function.

1

2

3
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Ableton Live

To make sure Wave works with Live, navigate to the top left corner 

of your screen to Live → Preferences → Link MIDI. Make sure Wave 

(Bluetooth) has Track and Remote toggled on.



In Softwave solo the function you want to map. Make sure your 

function has a dedicated CC number or Note.*



In Live navigate to MIDI in the top right corner, shortcut cmd+m 

(Mac) or ctrl+m (Windows).



Select the parameter you want to map.



Depending on which type of function you are mapping, move, tap or 

click on Wave to make the link.



Press MIDI again in Live. De-Solo the function. You should have 

mapped a function to a parameter in Live successfully.



Repeat for other functions.

1

2

3

4

5

6

7

* In order to map functions from Softwave to Ableton Live you need to attach 

a MIDI CC number to the function. 



You can assign any CC number, but make sure each function has an individual 

number. Softwave uses this number to communicate with your DAW.



Additionally you can assign:

PB (Pitchbend) to Tilt, Pan, Roll and Vibrato.



Notes (C, C#, D, E, F etc.) when using the Tap function.



Notes and Key commands/Shortcuts (cmd+T, R, f12 etc.) when using 

the Click function.

1

2

3
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Logic Pro X

To make sure Wave works with Logic Pro X, navigate to the top left corner 

of your screen to Logic Pro X → Preferences → MIDI... A preferences 

window opens up.



Navigate to the "Inputs" tab and make sure "Wave" is enabled.



In Softwave solo the function you want to map. Make sure your function 

has a dedicated CC number or Note.*



Make sure the track you're assigning to is record enabled.



A quick way to map a function to a parameter is to move the parameter 

you want to map. This is so Logic remembers the "last used parameter." 

Next navigate to Preferences → Control Surfaces and select Learn 

assignment for "x." You can also hit cmd+L on your keyboard for  

the same result. A window opens up.



Another way is to navigate to Preferences → Control Surfaces → 

Controller Assignment. A window opens up. Select "Learn." Move a 

parameter in Logic to map. With "Learn" selected move to the next step.



Depending on which of Wave's functions you are mapping, move, tap or 

click on Wave to make the link. Close the Controller Assignment window.



Now De-Solo the function in Softwave. The function should be mapped  

to Logic Pro X.



Repeat for other functions.

1
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Troubleshooting


If you're having trouble mapping Wave to a parameter try the following:

Make sure Wave is connected and active.



Try navigating to the top left corner of your screen to Logic Pro X → 

Preferences → General. A preferences window opens up. Navigate to 

"Advanced" and enable "Show Advanced Tools."



If this does not work, restart your computer.

1

2

3

* In order to map functions from Softwave to Logic Pro X you need to attach 

a MIDI CC number to the function. 



You can assign any CC number, but make sure each function has an individual 

number. Softwave uses this number to communicate with your DAW.



Additionally you can assign:

PB (Pitchbend) to Tilt, Pan, Roll and Vibrato.



Notes (C, C#, D, E, F etc.) when using the Tap function.



Notes and Key commands/Shortcuts (cmd+T, R, f12 etc.) when using 

the Click function.

1

2

3
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Pro Tools

To connect Wave to Avid's Pro Tools, navigate to Setup → Peripherals... → 

MIDI Controllers. Create a new controller in one of the four slots. Type should 

be "M-AudioKeyboard." Receive from "Wave, Bluetooth." Send to "Wave, 

Bluetooth." #Ch's "8."



There are several different ways to use Wave within Pro Tools.

CC  number



CC 17 to CC 24



CC 33 to CC 40



CC 41

CC  number



CC 12



CC 13



CC 14



CC 15

Function



Pan for tracks 1–8



Faders on tracks 1–8



Master Fader

Function



Mute selected track



Solo selected track



Move bank left



Move bank right

Mapping to Pro Tools' native Transport Controls and Parameters

Pro Tools has dedicated CC signals for a few native Transport Controls 

and Parameters.



In Softwave make sure every function you want to use to control Pro 

Tools' native Transport Controls and Parameters has a dedicated CC 

number (→ see Wave for Music Quickstart guide → Functions)



You can use Tilt, Pan, Roll and Vibrato for the following (→ see Wave for 

Music Quickstart guide → Functions)

1

2

3

You can use the Click Function for the following:4



21

CC  number



CC 49 to CC 56



CC 57



CC 109



CC 110



CC 111



CC 113



CC 116



CC 117



CC 118

CC  number



CC 114



CC 115

Function



Slider buttons (mute on tracks 1–8)



Flip button



Mode button



Previous track



Next track



Loop button



Stop



Play



Record

Function



Rewind



Fast forward

You can use the Momentary Click Function for the following


(→ see Wave for Music Quickstart guide → Click Function)

5

Additionally you can use Key Commands for Transport Control (→ see Wave 

for Music Quickstart guide → Functions).
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CC  number



CC 0 to CC 11



CC 16



CC 25 to CC 32	



CC 42 to CC 48	



CC 58 to CC 63	



CC 65 to CC 73	



CC 79 to CC 108	



CC 112	



CC 119	

Function



Customizable



Customizable



Customizable



Customizable



Customizable



Customizable



Customizable



Customizable



Customizable

Mapping to a Virtual Instrument Plugin

In Softwave make sure every function you want to use to control Pro 

Tools' native Transport Controls and Parameters has a dedicated CC 

number. (→ see Wave for Music Quickstart guide → Functions). 



As there are quite a lot of CC signals already taken by Pro Tools' native 

Transport Controls and Parameters you need to use one of the following 

CC signals:

1

2

In Softwave solo the function you want to map.



Create an → Instrument Track ← in Pro Tools.



Open the virtual instrument of choice, e.g. Xpand!2 which comes with Pro 

Tools.



Right-Click the parameter you want to control and select "Learn MIDI CC."



Now De-Solo the function in Softwave. The function should be mapped  

to Pro Tools.


3

4

5

6

7
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Important 1



You won't be able to control the parameter with Wave unless you arm 

the Instrument Track.

Important 2



Not all Virtual Instrument Plugins allow for MIDI Learn. This completely 

depends on the developer of the plugin. If nothing happens when you 

Right-Click a parameter in the plugin you can not assign MIDI to it.

CC  number



CC 0 to CC 11



CC 16



CC 25 to CC 32	



CC 42 to CC 48	



CC 58 to CC 63	



CC 65 to CC 73	



CC 79 to CC 108	



CC 112	



CC 119	

Function



Customizable



Customizable



Customizable



Customizable



Customizable



Customizable



Customizable



Customizable



Customizable

Mapping to an Audio Plugin

In Softwave make sure every function you want to use to control Pro 

Tools' native Transport Controls and Parameters has a dedicated CC 

number. (→ see Wave for Music Quickstart guide → Functions). 



As there are quite a lot of CC signals already taken by Pro Tools' native 

Transport Controls and Parameters you need to use one of the following 

CC signals:

1

2



24

In Softwave solo the function you want to map.



Create an →Audio Track← in Pro Tools.



Open the plugin you want to map to.



Now create a →MIDI Track← in Pro Tools.



On the "Input" choose "Wave, Bluetooth."



On the "Output" choose the plugin you put on the Audio Track.



Open the plugin.



Right-Click the parameter you want to control and select "Learn MIDI CC."



Now De-Solo the function in Softwave. The function should be mapped to 

Pro Tools.

1

2

3

4

5

6

7

8

9

Important 1



You won't be able to control the parameter with Wave unless you arm 

the MIDI Track.

Important 2



Not all Audio Plugins allow for MIDI Learn. This completely depends on 

the developer of the plugin. If nothing happens when you Right-Click a 

parameter in the plugin you can not assign MIDI to it.
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Cubase

CC  number



CC 1



CC 2



CC 4



CC 7



CC 8	



CC 10



CC 11



CC 16



CC 25



CC 64

Function



Modulation



Breath



Foot



Main Volume



Balance



Pan



Expression



Gen Purp1



Control 25



Sustain

To make sure Wave works with Steinberg's Cubase, navigate to the top 

menu of your screen to Studio → Studio Setup. The MIDI Port Setup 

window should have opened.



Find "Wave IN" on the list of devices and make sure "In 'All MIDI Ins' is 

enabled.



Cubase has mappings auto-assigned. In Softwave map the function you 

want to use to one of the following CC signals:

1

2

3

Wave should automatically control the selected CC in Cubase.
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To assign Wave to a 3rd party plugin, solo the function you want to map 

within Softwave. Make sure your function has a dedicated CC number or 

Note (→ see Wave for Music Quickstart guide → Functions) that is not 

already auto-assigned in Cubase.



In the 3rd party plugin right click on the parameter you want to map. 

Many plugins allow "MIDI Learn." Select "MIDI Learn" if available.



Depending on which of Wave's functions you are mapping, move, tap or 

click on Wave to make the link.



Now De-Solo the function in Softwave. The function should be mapped to 

the parameter in the 3rd party plugin within Cubase.



Repeat for other functions.

4

5

6

7

8

Reason

To make sure Wave works with Reason, navigate to Reason → Preferences 

→ Control Surfaces. Look under "Easy MIDI Inputs" and make sure you 

can see Wave and it is enabled.



In Softwave solo the function you want to map. Make sure your function 

has a dedicated CC number or Note.



To map the function within Reason right click on the parameter you want 

to map and select "Edit Remote Override Mapping..."



Make sure Wave is chosen as the Control Surface and check "Learn from 

control surface input."



Depending on which of Wave's functions you are mapping, move, tap or 

click on Wave to make the link.



Now De-Solo the function in Softwave. The function should be mapped to 

Reason.



Repeat for other functions.

1

2

3

4

5

6

7
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FL Studio

To make sure Wave works with Image-Line's FL Studio, navigate to the 

top left corner of your screen to FL Studio → Preferences → MIDI. Find 

Wave Bluetooth in the input device list and select Enable under the list.



In Softwave solo the function you want to map. Make sure your function 

has a dedicated CC number or Note (→ see Wave for Music Quickstart 

guide → Functions).



To map the function to a native plugin within FL Studio right click on the 

parameter you want to map and select "Link to Controller."



To map the function to a 3rd party plugin right clicking doesn't work. 

Instead move the parameter you want to map, for FL Studio to remember 

the last used parameter. Next go to Tools → Last tweaked and select "Link 

to Controller."



Depending on which of Wave's functions you are mapping, move, tap or 

click on Wave to make the link.



Now De-Solo the function in Softwave. The function should be mapped to 

FL Studio.



Repeat for other functions.

1

2

3

4

5

6

7
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Reaper

To make sure Wave works with Reaper, navigate to Reaper→ Preferences 

→ Audio → MIDI Devices. Under MIDI Inputs, right-click on Wave and 

make sure both "Enable input" and "Enable input for control messages" 

are checked.



In Softwave solo the function you want to map. Make sure your function 

has a dedicated CC number or Note (→ see Wave for Music Quickstart 

guide → Functions).



To map the function to native transport controls within Reaper, hover over 

the parameter and notice it's name. Then head to "Actions → Show action 

list..." and search for the parameter in the list. Select the parameter and 

click "Add..." under "Shortcuts for selected action."



To map the function to a 3rd party plugin, first move the parameter you 

want to map. Then click "Param" and verify that "Last touched" matches 

the parameter you want to map. Then select "Learn."



Depending on which of Wave's functions you are mapping, move, tap or 

click on Wave to make the link.



Now De-Solo the function in Softwave. The function should be mapped to 

Reaper.



Repeat for other functions.

1

2

3

4

5

6

7
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Bitwig

To make sure Wave works with Bitwig Studio, navigate to File → Settings 

→ Controllers. Click Add → Generic → MIDI Keyboard. In the MIDI 

device drop-down, select Wave's input.



In Softwave solo the function you want to map. Make sure your function 

has a dedicated CC number or Note (→ see Wave for Music Quickstart 

guide → Functions).



To map the function to native transport controls within Bitwig, right-click 

the parameter you want to map and select "Map to Controller or Key."



To map the function to a 3rd party plugin, first move the parameter you 

want to map. You should see the name of the parameter displayed on the 

device in the Fx-chain. Right-click the parameter and select "Map to 

Controller or Key."



Depending on which of Wave's functions you are mapping, move, tap or 

click on Wave to make the link.



Now De-Solo the function in Softwave. The function should be mapped to 

Bitwig Studio.



Repeat for other functions.

1

2

3

4

5

6

7
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Studio One

To make sure Wave works with Presonus' Studio One, navigate to File 

→ Preferences → External Devices. Click "Add..." Select "New Control 

Surface" from the list on the left. Rename "Device Name" to "Wave" or 

similar. Under "Receive From" choose "G1W1 Bluetooth." Click "OK."



In Softwave make sure every function you want to map over to Studio 

One has a dedicated CC number or Note (→ see Wave for Music 

Quickstart guide → Functions).



In Studio One open the Mix console by pressing "Mix" in the lower 

right corner. Then press "External" on the other side of the screen, in 

the lower left corner.



On the list that opens press the arrow beside the name of your Control 

Surface ("Wave") and select "Edit..." The External Devices window 

opens up.



Press "MIDI Learn." All of Softwave's functions that are active at that 

given time will be recognised in Studio One. Depending on which of 

Wave's functions you are mapping, move, tap or click on Wave to 

make the link. Disable "MIDI Learn."



In Softwave solo the function you want to map.



Next Right-click a parameter in Studio One and select "Assign 

parameter name to Control# on Wave."



Now De-Solo the function in Softwave. The function should be 

mapped to Studio One.



When you link Tap and Click to Studio One the MIDI message for 

these functions will be registered as a Knob. With "MIDI Learn" 

enabled right click each Knob you want to change and select Button. 

Then right click again and select "Assign Command..." From the list 

select the command you want to assign.



Repeat for other functions.
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Cakewalk

To make sure Wave works with Cakewalk, navigate to Edit → 

Preferences → MIDI → Devices. Make sure Wave is checked under 

MIDI input.



In Softwave solo the function you want to map. Make sure your 

function has a dedicated CC number or Note (→ see Wave for Music 

Quickstart guide → Functions).



In Cakewalk right click the parameter you want to control and 

navigate to Remote control → Click "Learn." Select "Ok."



Depending on which of Wave's functions you are mapping, move, tap 

or click on Wave to make the link.



Now De-Solo the function in Softwave. The function should be 

mapped to Cakewalk.



Repeat for other functions.
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NI Traktor Pro 3

To map Wave to a slider or a knob in Traktor Pro 3 navigate to Traktor's 

Preferences → Controller Manager.



Under Device, select Add → Generic MIDI



In Softwave solo the function you want to map (the "S"). Make sure 

your function has a dedicated CC number.*



Navigate back to Traktor's Controller Manager. Click "Add In..." and 

select the effect you'd like to assign (e.g. Dry/Wet Adjust or X-fader 

position).



Click "Learn" and move Wave accordingly to make the link.



You should now see the MIDI CC change next to the Learn button. 

Press "Learn" again when finished to disable the learning mechanism.



In Softwave de-solo the function (the "S"). Now you've mapped a 

movement function to a parameter in Traktor Pro 3 successfully.
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To make sure Wave works with Traktor Pro 3, navigate to the top left corner of your 

screen to Preferences → Audio Setup. Make sure you've selected an audio device.

Mapping movements

To map Wave to a button in Traktor Pro 3 navigate to Traktor's 

Preferences → Controller Manager.



Under Device, select Add → Generic MIDI



Click "Add In..." and select the button you'd like to assign  

(e.g. Play or FX unit 1 on).



In Softwave add a "Click" function and give it a MIDI CC number.*
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Mapping the click function
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You need to specify in both Softwave and Traktor Pro 3 what type  

of button interaction you want to use:



For a "Click" function (to toggle buttons on/off):









For a "Hold" function (to activate while pressing the button):








Click "Learn" and press the button on Wave (the one you chose in 

Softwave) to make the link.



You should now see the MIDI CC change next to the Learn button. 

Press "Learn" again when finished to disable the learning mechanism.



Now you've mapped one of Wave's buttons to a function in Traktor 

Pro 3 successfully.

In Softwave make sure the action is set to "Click" and the type 

is set to "Trigger" (lower left corner of the function window).



In Traktor's Controller Manager select "Toggle" under 

"Interaction Mode."





In Softwave make sure the action is set to "Momentary."



In Traktor's Controller Manager select "Hold" under 

"Interaction Mode."
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* In order to map functions from Softwave to Traktor Pro 3 you need to 

attach a MIDI CC number to the function.



You can assign any CC number, but make sure each function has an individual 

number. Softwave uses this number to communicate with your DAW.



Additionally you can assign:

PB (Pitchbend) to Tilt, Pan, Roll and Vibrato.



Notes (C, C#, D, E, F etc.) when using the Tap function.



Notes and Key commands/Shortcuts (cmd+T, R, f12 etc.) when using 

the Click function.
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Wave’s Configuration Panel 

To access Wave's configuration panel press the gear-icon behind a connected 

Wave in the top left corner of Softwave. In the panel you can change Wave's name, 

Reset its movements, configure buttons and configure Wave's standalone mode.

Rename Wave



To rename Wave right-click on a connected "Wave," select 'Rename' and type 

in a new name.



Renaming Wave can come in handy when you have more than one Wave, or if 

you simply want to identify your own Wave from the ones of your friends.



Wave on Right or Left index finger



Depending on what you are doing it might come in handy to have Wave on 

your left index finger instead of the right one.



Wave is symmetrical so this is easily possible. In order to flip the screen as well 

as the motion detection algorithms press "R" (Right). It should now read "L" 

(Left). Repeat to change it back.



Activating Wave from Softwave



Activating Wave from Softwave is made possible so one person can wear Wave 

and another one can control it.





Reset Wave's movements from Softwave



Resetting Wave's movements from Softwave is made possible so one person 

can wear Wave and another one can control it.

Press this icon.

Press this icon.
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Button configuration



You can configure all buttons to your liking, using either a Click or a Long Press 

(or both).

Reset button configuration



If you ever want to reset the button configuration to its default state press Reset 

button configuration.



If you want to undo the resetting of the buttons you can use the undo command, 

cmd+z (Mac) or ctrl+z (Windows).



Button icons



These icons identify which button you are configuring.

Button command list



Select a command from a drop down menu for each button;

Click


A Click is when you press a button once to activate a command.	



Long Press


A Long Press is when you press a button down and hold it to activate a 

command. The command mapped to Hold is activated after half a second.

Middle button Up button Down button

Next Preset - Navigates to the next preset within Softwave.



Previous Preset - Navigates to the previous preset within Softwave.



Reset Movements - Resets movements to their starting point.



Edit Mode - Lets you enter Edit Mode (only in Standalone mode)
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Standalone Mode editor



Standalone Mode is when you use Wave without Softwave.





The changes you make are saved to Wave automatically.



Wavefront editor



If you have the Wavefront receiver, you can edit how Wave behaves when 

connected to it.





The changes you make are saved to Wave automatically.



Activate - Activates and deactivates a Wave.



Momentary activate - Activates Wave while holding the button.



Show Battery - Shows the battery status of Wave.
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To enter the Standalone Mode editor, press this icon.

To enter the Wavefront editor, press this icon.
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Menu

You find Softwave's menu in the top left corner of your screen.

Audio/MIDI settings



In Audio/MIDI Settings you canE

A Mute and unmute audio input<

A Select the preferred audio output<

A Select an input device<

A Change the Sample Rate<

A Change the Audio buffer Size<

A Select active MIDI inputs<

A Test if the sound is working properly.



Scan for plugins



You need to scan for the plugins on your computer for Softwave to know which 

plugins are available. You can scan for VST3 and AU plugins.



Undo/Redo



You can use Undo and Redo to undo or redo your last actions.



You can also use cmd+z / cmd+shift+z (Mac) or ctrl+z / ctrl+shift+z (Windows) 

for the same results.



Save



Saves the preset bank you're working within.



New preset bank



Create a blank preset bank.



Load default preset bank



Load the original Preset Bank that Softwave came with.
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Shortcuts

Use these shortcuts to control a few practical things in Softwave.

SAVE PRESET BANK

SAVE PRESET BANK

OPEN AUDIO/MIDI SETTINGS

OPEN AUDIO/MIDI SETTINGS

UNDO

UNDO

REDO

REDO

CMD S+

CTRL S+

CMD ,+

CTRL ,+

CMD Z+

CTRL Z+

CTRL Y+

SHIFTCMD Z+ +

Key shortcuts: Mac

Key shortcuts: Windows
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Standalone Mode

Overview



Wave can be used as a stand alone MIDI controller with your iPad, iPhone or 

Android device or by using WIDI Master by CME which allows you to connect 

Wave straight to your hardware instrument, without the need of a computer.



As a default Wave only has one preset in Standalone mode and the CC numbers 

Wave sends, and each movement's range is predetermined.



You can configure how Wave behaves in Standalone mode, creating presets and 

customising everything to your liking, by using Softwave's Standalone mode 

editor, on your mac or windows computer.



The LED display indicates whether Wave is active or not. A stable horizontal line 

indicates that Wave is inactive while interactive horizontal and vertical lines 

indicate that Wave is actively sending data to your device.
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Roll (CC 18)



Roll hand side to side  

to control parameters.

Vibrato (Pitch Bend)



Move Wave sideways  

to control parameters.

Tap (Note C1 (36))



Hit any surface to trigger 

samples or notes.

Click (CC 21)



Issue commands and 

navigate presets.

Tilt (CC 16)



Tilt hand vertically  

to control parameters.

Pan (CC 17)



Pan hand horizontally  

to control parameters.

Standalone Mode default values
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Default button settings



Wave has 3 buttons you can reach with your thumb. Each button has 

a certain function.

Click middle

button to activate/ 
deactivate Wave

Click lower 
button for click  
function (CC 21)

Long press  
upper button  
to enter/exit 
edit mode

Long press  
to reset  
movements
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Connecting Wave

To connect Wave make sure it is turned on. You turn Wave on by pressing its 

Middle button. Also make sure Bluetooth is turned on in your device.



iPad and iPhone



You can connect Wave to your iPad and iPhone. It works on an app-to-app basis 

so you need to connect Wave through the application you want to use it with  

- not through the regular Bluetooth Settings.

Android

Turn Wave on. Make sure Bluetooth is turned on on your device.



Navigate to the app you want to use Wave with.



Find the app's settings (usually a wrench or a gear icon) and find 

Bluetooth MIDI (as long as the app supports Bluetooth MIDI devices).



You should see Wave on a list of Bluetooth MIDI devices. Press connect.



If the app you're using does not provide an option to pair Bluetooth 

MIDI devices, download this application and use it connect Wave to 

your device.
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Turn Wave on. Make sure Bluetooth is turned on on your device.



Navigate to the system settings (gear icon).



Select Connected Devices and select Bluetooth.



Select Pair new device.



You should see Wave on the list. Press it to connect it.



Once your Bluetooth MIDI device is paired, it’ll show up in the list 

of Paired devices.



Now go over to the application you want to use Wave with (as long 

as it can send MIDI) and map the functions to parameters.
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WIDI Master

The WIDI Master consists of two units. The bigger unit connects to the MIDI 

OUT port of your instrument, and the smaller unit connects to MIDI IN.



Turn Wave on and keep it close to WIDI Master.



Now turn your instrument on, or plug WIDI Master into an instrument that  

is already turned on.



Wave should connect automatically to WIDI Master.



When WIDI Master is searching for a connection it flashes a blue light, 

which becomes steady when it connects to a device.
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If Wave does not connect:

Try unplugging WIDI Master and plugging it back in.



Try turning your instrument on and off.



Make sure neither device is connected to anything else, for example 

your computer or Wavefront.
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Mapping to an app

Mapping Wave to parameters in apps can vary from one app to the other. These 

instructions are related to how you use Wave when mapping and not how you 

enable MIDI mapping or select parameters to map within your app of choice.



Mapping to an app: Movements, Vibrato and Tap

Mapping to an app: Click

With MIDI mapping enabled in your app, select the parameter you 

want to map.



Enter Edit Mode on Wave (hold Up button) and navigate to the 

function you want to map - each represented by its icon. Edit Mode 

solos each function so Wave only sends the CC number for that 

particular function.



Depending on the function you're mapping, move or tap Wave. The 

function should be mapped instantly.



Repeat for other functions.



Disable MIDI mapping in your app and exit Edit Mode (hold Up 

button again) when done.
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With MIDI mapping enabled in your app, select the parameter you 

want to map.



Press the button on Wave assigned to the Click Function (Default is 

the Down button).



Disable MIDI mapping in your app.
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Softwave's Standalone mode editor

Edit mode

When Wave is not connected to Softwave, it's in a mode called Standalone 

mode. You can configure this mode using Softwave's Standalone mode editor.

'Edit mode' allows you to adjust presets on Wave it self, without going back to 

the computer. 'Edit mode' consists of a main menu, which is an overview of the 

preset's functions and submenus for each function, where you can adjust them.



'Edit mode' does not allow you to create new presets, it merely allows you to edit 

the presets you've already created using Softwave's Standalone mode editor.



You can MIDI Learn CC and Program Change values, manually change CC and 

note values, adjust movement range, sensitivity, output range and more.

Wave supports up to 24 presets in Standalone mode. When you make changes 

in the standalone mode editor, the changes are saved immediately to Wave. 

The preset configuration is exactly the same as in the main view, the only 

difference being that the main view presets do not get saved to Wave.

The standalone mode editor can be accessed by clicking this icon.

Enter/Exit Edit Mode



Enter 'Edit mode' by doing a long press on the UP button. Exit 'Edit mode' 

the same way.

Long press  
upper button  
to enter/exit 
edit mode
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Navigation



Move between screens by clicking the UP and DOWN button.

Enter/Exit Submenus



Enter a function's submenu by clicking the MIDDLE button. Exit a function's 

submenu by doing a long press on the UP button.

Click upper 
button for

next screen

Click lower 
button for 
previous  
screen

Click middle 
button to

enter submenu

Long press  
upper button 
to exit submenu
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Shortcut to MIDI Learn



Shortcut to MIDI LEARN by doing a long press on the MIDDLE button in the main 

menu view.

Adjusting functions



Adjust anything by clicking the MIDDLE button. Click again when finished.

Long press  
middle button  
for shortcut  
to midi learn

Click middle  
button to adjust
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Edit mode: Main menu

Move between screens by clicking the UP and DOWN button.

Click upper 
button for

next screen

Click lower 
button for 
previous  
screen

RE/AB - Relative, Absolute



You can decide if a preset uses Relative (RE) or Absolute (AB) movements. The 

default state for Wave is Relative.



Relative mode behaves in a way that when you deactivate Wave, no matter how 

you move your hand in between, when you reactivate it Wave will start tracking 

from the last position before deactivating.



The Absolute mode does the opposite. It keeps tracking your movements even if 

you've deactivated Wave, and "jumps" to the current value when you reactivate 

it.



Absolute is stuck in space, Relative moves with you.



Click MIDDLE button to change.

Relative movements Absolute movements
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R/L - Right, Left



Use this feature dependant on if you wear Wave on your left or right index finger. 

Click MIDDLE button to change.

Ch - Channel



Use this feature to change the preset's MIDI Channel. Click MIDDLE button to 

change. Use UP and DOWN buttons to find your channel of choice. Click MIDDLE 

button again when finished.

PC - Program Change



Use this feature to MIDI Learn a Program Change onto the preset. This way, every 

time you navigate to this particular preset it will send out a program change to 

your hardware device. Click MIDDLE button to activate MIDI Learn. Select the 

program change on your hardware device. It should register automatically.

Right

Ch or Channel shows  
up momentarily

Ch or Channel shows  
up momentarily

Left - L upside down

(intended for your left hand)

Channel number
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Edit mode: Submenus

Enter a function's submenu by clicking the MIDDLE button. Exit a function's 

submenu by doing a long press on the UP button.

Movement Sensitivity (Vibrato)



You can change the sensitivity of the Vibrato by clicking the MIDDLE button 

and then adjust the sensitivity by using the UP and DOWN buttons.



The sensitivity block has 5 stages represented by lines. The more lines the 

block has the more sensitive the Vibrato is. Click the MIDDLE button again 

when finished.

Low sensitivity High sensitivity

Click middle 
button to

enter submenu

Long press  
upper button 
to exit submenu
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Movement Direction (Tilt, Pan, Roll & Vibrato)



You can invert the movement direction by clicking the MIDDLE button on Wave. 

When you do the arrow should flip.



This will make the parameter you are controlling move in the opposite direction 

of your movement.

CC Value



You can adjust the CC value for each function. There are two ways possible to do 

this.



Either click the MIDDLE button and use the UP and DOWN buttons to change the 

number manually. Click the MIDDLE button again when finished.



Or click the MIDDLE button to activate MIDI Learn. Simply turn a knob on your 

hardware device and its CC number should register automatically.



*Pro Tip - You can shortcut your way to MIDI Learn in the main menu by holding 

the MIDDLE button.

Tilt default direction Pan default direction Roll default direction

CC shows up  
momentarily

CC number
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Output Range (Tilt, Pan, Roll & Vibrato)



You can adjust each function's Output range. The default is 0-127 but you can 

change this number manually using the UP and DOWN buttons.



There are two screens for this feature, one for the min Output and another one 

for the max Output.



Click the MIDDLE button and change the number. Click again when finished.



You can also use a parameter on your synth to adjust the number.

Trigger Sensitivity (Tap)



You can change the sensitivity of the Tap by clicking the MIDDLE button and 

then adjust the sensitivity by using the UP and DOWN buttons.



The sensitivity block has 5 stages represented by lines. The more lines the block 

has the more sensitive the Tap is. Click the MIDDLE button again when finished.

Output min shows up 
momentarily

Low sensitivity

Output min number

High sensitivity

Output max shows up 
momentarily

Output max number


